This article describes an issue that can arise with Atlas and ConneX filters after tags which are already used in the system have been merged inside their term set. This is based on the default behaviour of the Term Store and SharePoint when terms are merged.
Symptoms
This issue can be observed in ConneX when workspaces are using metadata tags that were originally different terms with different IDs and were later merged into a single term. The workspaces themselves will then be using different IDs to represent the merged term despite having the same label, which causes it to appear mutliple times in filters, like the example below for Bank of Laska where 3 different terms were merged into 1:
When selecting one of these duplicate tags, results for all of the duplicates are shown whichever duplicate is picked.
In Atlas Search, you can experience the issue in a very similar way. When clicking on a search filter to see the available values you may see duplicated terms, and whichever of the duplicates you pick it will include results from all of them.
Cause
This issue is caused by merging tags in the term store that have already been used in the system. Each term when created has an associated GUID (unique identifier), and when merged the original GUID in the SharePoint metadata field is not updated - simply the old GUID now also refers to the new term. As a result in some instances such as the search filters shown above, each GUID associated to the term via merges will have its own instance of the term.
Resolution
To resolve this issue, you'll need to edit each affected workspace from the ConneX card, or for Atlas edit each piece of content, then clear the affected term, reapply it and submit your change to the workspace / save the item in Atlas with the term reapplied.
Doing this for all workspaces / content matching the filter will ensure that all those workspaces / content are using the same ID for the term and the duplication will be usually disappear within an hour after the changes are applied when the search crawl detects the updated metadata.
Still need help?
If you're still having trouble or have further questions please contact support or your CSM.
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